Jump to content

GizROM 3.0 per ZUK Z2 (ZUI 3.1.117)


Emanuele C
 Share

Recommended Posts

Dopo uno sviluppo lento e travagliato, ecco finalmente la nuova GizROM 3.0 per ZUK Z2 basata sulla ZUI 3.1!

La ROM, valida sia per gli Z2 indiani che per quelli cinesi, riprende il nuovo firmware originale ma aggiunge quel "pizzico di italianità" tipico delle GizROM. La lista delle caratteristiche di questa prima versione include la localizzazione in diverse lingue europee (italiano, tedesco, francese,  spagnolo, russo, polacco, ungherese) e la rimozione delle app cinesi. Le Gapps (pico) sono preinstallate.

La ROM, nonostante i nostri test interni, potrebbe non essere priva di bug.

Feedback e segnalazioni, come sempre, sono graditi.

Changelog

Spoiler

Changelog 3.0

  • Basata sul firmware ZUI 3.1.117 cinese (Nougat 7.0);
  • tradotte le nuove sezioni;
  • bugfix e ottimizzazioni.

 

Installazione

Spoiler

IMPORTANTE: La procedura descritta in questa guida presenta operazioni complesse che, se eseguite in maniera scorretta, potrebbero danneggiare il vostro device. Si consiglia l’esecuzione solo da utenti che abbiano maturato una buona esperienza in ambito modding. Lo staff di GizChina.it non si riterrà responsabile per eventuali danni al dispositivo.

Prerequisiti

Procedura

Prima installazione

  1. Copiare il pacchetto GizROM sul telefono;
  2. entrare in recovery ( scegliere all'accensione la voce recovery con i tasti volume e selezionarla con power);
  3. pulire le partizioni Data, Cache e Dalvik Cache;
  4. installare la ROM da TWRP;
  5. riavviare il dispositivo.

Aggiornamenti da versione precedente della GizROM

  1. Copiare la GizROM sul telefono;
  2. entrare in recovery ( scegliere all'accensione la voce recovery con i tasti volume e selezionarla con power);
  3. pulire le partizioni Cache e Dalvik Cache;
  4. installare la ROM da TWRP;
  5. riavviare il dispositivo.

Vi piacciono le nostre GizROM e desiderate che vengano rilasciati aggiornamenti? Le donazioni Paypal sono una misura dell'interesse da parte della community!

Link to comment
Share on other sites

Il 14/12/2017 at 16:24, erik42788088 dice:

come mai è stata chiusa la precedente discussione ed è aperta questa?

Purtroppo abbiamo avuto grossi problemi con il server, sul backup che abbiamo ripristinato questa discussione non c'era

@Axospirit Non è prevista al momento, di solito le GizROM con Pixel Launcher sono basate sul firmware indiano (questo è cinese)

Link to comment
Share on other sites

Complimenti per la ROM!!! Vengo da Custom Rom (D.U., Aex, AICP, Lineage, Carbon) ma devo riconoscere che con questa rom  il telefono è estremamente più reattivo. Segnalo solo un bug: l'app. Facebook crasha. Ma si sopravvive cmq!!! Grazie per l'ottimo lavoro!!!

Link to comment
Share on other sites

27 minuti fa, Dixone dice:

Complimenti per la ROM!!! Vengo da Custom Rom (D.U., Aex, AICP, Lineage, Carbon) ma devo riconoscere che con questa rom  il telefono è estremamente più reattivo. Segnalo solo un bug: l'app. Facebook crasha. Ma si sopravvive cmq!!! Grazie per l'ottimo lavoro!!!

Se installi Facebook lite funziona perfettamente. 

Sono l'unico a cui la fotocamera anteriore fa in qualsiasi condizione di luce, foto sfocate e granulose? 

Link to comment
Share on other sites

Vorrei segnalare che con Facebook lite e Messenger lite non si hanno crash! Ma anche Google Maps A me crasha (da oggi) e prime video dice unsupported device.

Inoltre vorrei sapere se sulle precedenti versioni c'era la possibilità di impostare l'auto spegnimento e accensione per giorni determinati della settimana o come in questa versione solo per tutti i giorni.

Inoltre ho riscontrato il seguente comportamento:

Se il telefono si spegne da solo mentre è sotto carica, quando si riaccende rimane sul display nero con led acceso. Per avviarlo bisogna tenere premuto il pulsante accensione andare in bootloader e dare power off da lì e poi riaccenderlo manualmente. Dando i comandi dal menù zuk non funziona nulla...neanche entrare in recovery.

Invece se si spegne il telefono e successivamente lo si collega al caricabatterie  la riaccensione avviene normalmente.

Non so se è un bug o no.

Link to comment
Share on other sites

Spero sia il posto adatto del forum per chiedere, ma qualcuno ha problemi con l'hotspot?

Scheda 1 h3g naviga ma niente hotspot (i portatili prendono i parametri di rete ma non navigano) scheda2 Tim invece navigo in hotspot ma non con il browser del telefono. Domani provo ad invertire le sim, ma tempo siano gli APN configurati male. Qualcuno ha verificato il funzionamento della funzione hotspot?

Link to comment
Share on other sites

8 ore fa, Enzo.cons dice:

Spero sia il posto adatto del forum per chiedere, ma qualcuno ha problemi con l'hotspot?

Scheda 1 h3g naviga ma niente hotspot (i portatili prendono i parametri di rete ma non navigano) scheda2 Tim invece navigo in hotspot ma non con il browser del telefono. Domani provo ad invertire le sim, ma tempo siano gli APN configurati male. Qualcuno ha verificato il funzionamento della funzione hotspot?

A me con scheda Tim l'hotspot entrava in connessione ma non riuscivo a navigare. Ho provato ad impostare manualmente il DNS dell'IPV4 del dispositivo da connettere (Pc con s.o. Linux - Kubuntu) utilizzando quelli di Google (8.8.8.8, 8.8.4.4) e va tutto alla grande!!!

Link to comment
Share on other sites

20 minuti fa, Dixone dice:

A me con scheda Tim l'hotspot entrava in connessione ma non riuscivo a navigare. Ho provato ad impostare manualmente il DNS dell'IPV4 del dispositivo da connettere (Pc con s.o. Linux - Kubuntu) utilizzando quelli di Google (8.8.8.8, 8.8.4.4) e va tutto alla grande!!!

Grazie ad entrambi (Jojo_0n) ma la scheda che mi interessa usare con hotspot è quella della 3, inoltro la sim tim credo che la chiuderò per tornare in vodafone (Dove l'hotspot si paga....). Volevo chiede se anche a te, mentre hai l'hot spot attivo, il telefono non è in gradi di navigare....

Credo il problema sia proprio la configurazione degli hotspot. Mettere un dns a mano non sarebbe affatto un problema.

Link to comment
Share on other sites

24 minuti fa, Enzo.cons dice:

Grazie ad entrambi (Jojo_0n) ma la scheda che mi interessa usare con hotspot è quella della 3, inoltro la sim tim credo che la chiuderò per tornare in vodafone (Dove l'hotspot si paga....). Volevo chiede se anche a te, mentre hai l'hot spot attivo, il telefono non è in gradi di navigare....

Credo il problema sia proprio la configurazione degli hotspot. Mettere un dns a mano non sarebbe affatto un problema.

Con Hotspot attivato, navigo sia con il telefono che con il dispositivo collegato, in contemporanea.

Link to comment
Share on other sites

2 ore fa, jojo_0n dice:

idem x me ( ho Tim )

Grazie sempre ad entrambi, stamattina ho riprovato con Tim ed in effetti l'hotspot funziona con entrambi i dispositivi in navigazione (portatile e zuk stesso). Probabilmente ieri c'è stato un qualche disservizio su rete tim e ho dato subito la colpa al telefono.

Switchando i dati su h3g invece continua ad essere tutto invariato, telefono che naviga ma notebook a secco. Non pinga neanche ip pubblici noti. Stasera metto la sim un altro telefono e vedo com'è configurato l'apn.

 

PS: Altra anomalia non riesco più ad accadere alle reti wifi con ssid nascosto. Se sulla stessa rete abilito il broadcast del nome funziona, appena lo spengo perdo il segnale :(

Link to comment
Share on other sites

Salve a tutti, volevo fare una domanda, io sul.mio zuk z2 ho una rom modificata e volevo sapere se per metterci questa devo riportarlo alla rom originale poi fare tutte le procedure o posso metterla direttamente facendo anche il sole system? Grazie

 

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...