Jump to content

Boot loop dopo aggiornamento manuale nubia z11


NicoeNNe
 Share

Recommended Posts

Salve a tutti, inizio col chiedere scusa se farò qualche errore nell'apertura di una nuova discussione poiché è la prima volta. Come da ditolo ho provato ad aggiornare alla versione internazionale 1.20 il mio z11 "d'oltreoceano" che aveva una rom basata su quella cinese, l'ho fatto con l'updater presente sullo smartphone. Questo ha provocato un bootloop a cui ho potuto rimediare solo eseguendo un wipe totale dalla recobery stock. Ora mi ritrovo con una versione internazionale stock 1.20 che funziona bene ma ad ogni avvio causa bootloop, qualcuno mi può aiutare? Sul forum nubia ho letto che prestano assistenza solo ai dispositivi internazionali.

Link to comment
Share on other sites

1 ora fa, NicoeNNe dice:

Salve a tutti, inizio col chiedere scusa se farò qualche errore nell'apertura di una nuova discussione poiché è la prima volta. Come da ditolo ho provato ad aggiornare alla versione internazionale 1.20 il mio z11 "d'oltreoceano" che aveva una rom basata su quella cinese, l'ho fatto con l'updater presente sullo smartphone. Questo ha provocato un bootloop a cui ho potuto rimediare solo eseguendo un wipe totale dalla recobery stock. Ora mi ritrovo con una versione internazionale stock 1.20 che funziona bene ma ad ogni avvio causa bootloop, qualcuno mi può aiutare? Sul forum nubia ho letto che prestano assistenza solo ai dispositivi internazionali.

Non puoi aggiornare il tuo cellulare "cinese" con l'updater presente sul telefono con la versione internazionale della rom perchè non sono compatibili. In quel modo puoi aggiornare solo i dispositivi "italiani" venduti sul sito Nubia italia.

Detto questo, per risolvere la cosa devi montare un recovery TWRP (va benissimo anche quella che trovi in questo forum) e poi con quella facendo tutti i wipe del caso puoi montare tutto quello che ti pare, anche la 1.20 internazionale

Link to comment
Share on other sites

Ti confermo che se vuoi montare la 1.20 internzionale devi farlo da TWRP e se fai tutti i wipe non va in bootloop. Attento però che se vuoi montare l'ultima Gizrom 1.4 per farlo devi sostituire il file boot.img presente nella rom con quello della internazionale, altrimenti ti va ancora in bootloop.

Un'ultima cosa, se vuoi mantenere la TWRP anche dopo aver installato la 1.20, prima di installarla devi scompattare il file ed andare nella cartella system. Quando sei lì devi cancellare il file "recovery-from-boot.p", se non lo fai una volta montata la rom ti ritroverai la recovery nubia

Link to comment
Share on other sites

5 minuti fa, moste dice:

Ti confermo che se vuoi montare la 1.20 internzionale devi farlo da TWRP e se fai tutti i wipe non va in bootloop. Attento però che se vuoi montare l'ultima Gizrom 1.4 per farlo devi sostituire il file boot.img presente nella rom con quello della internazionale, altrimenti ti va ancora in bootloop.

Perché la Gizrom è basata su quella cinese, giusto? E gli "wipe del caso" sarebbero tutti quelli presenti? Per andare sul sicuro

Link to comment
Share on other sites

48 minuti fa, NicoeNNe dice:

Perché la Gizrom è basata su quella cinese, giusto? E gli "wipe del caso" sarebbero tutti quelli presenti? Per andare sul sicuro

No, la Gizrom 1.4 è basata sulla internazionale. Gli wipe da fare sono:

dalvik

cache

data

system

Link to comment
Share on other sites

2 ore fa, moste dice:

No, la Gizrom 1.4 è basata sulla internazionale. Gli wipe da fare sono:

dalvik

cache

data

system

Allora non capisco perché dovrei modificare il file di boot con la gizrom per evitare il loop, anche perché non saprei quale mettere. A questo punto mi chiedo quale sia meglio montare

Link to comment
Share on other sites

4 minuti fa, NicoeNNe dice:

Allora non capisco perché dovrei modificare il file di boot con la gizrom per evitare il loop, anche perché non saprei quale mettere. A questo punto mi chiedo quale sia meglio montare

Te l'ho scritto prima. Il file è il boot.img

La spiegazione è tecnica. Se vuoi saperla vai in modding alla discussione della gizrom

Link to comment
Share on other sites

Nella GizROM abbiamo modificato il file di boot per rimuovere l'obbligo di crypt della memoria, ma questa modifica sembra dare problemi ad alcuni dispositivi sia cinesi che internazionali. Non abbiamo ancora ben capito come eliminare del tutto il problema, però conosciamo il workaround che consiste, come detto giustamente da moste, nel sostituire il boot.img della ROM con quello originale. 

Se decidi di mettere la GizROM secondo me la procedura più sensata consiste nel provare con lo zip normale (in pratica seguire semplicemente la guida al primo post della discussione ufficiale)  e, solo in caso di problemi, riprovare con quello modificato a mano con il boot originale.

Link to comment
Share on other sites

...niente, non riesco... mi blocco, ecco i passaggi problematici:

(...fatti i precedenti senza intoppi)

  • terminata l'installazione colleghiamo lo smartphone al computer ed avviamo il file "GizTWRP.bat" sempre presente nella cartella appena scompattata;
  • premiamo "1" sulla tastiera seguito dal tasto "invio" per flashare la recovery;
  • il telefono si riavvierà in automatico nella recovery TWRP;

Il .bat mi da gli ok ma si apre il menù fastboot in riavvio...niente recovery TWRP!

dove sbaglio???

Link to comment
Share on other sites

1 ora fa, Emanuele C dice:

Il telefono dovrebbe riavviarsi per pochi secondi in fastboot, e poi dovrebbe apparire la TWRP. I driver sono installati correttamente (autorun.exe nella cartella GizTWRP)?

sto riscontrando lo stesso problema pure io, il telefono rimane in fastboot. i driver li ho installati correttamente, era il caso di riavviare il pc dopo averlo fatto?

 

Link to comment
Share on other sites

44 minuti fa, NicoeNNe dice:

sto riscontrando lo stesso problema pure io, il telefono rimane in fastboot. i driver li ho installati correttamente, era il caso di riavviare il pc dopo averlo fatto?

 

provato in tutti i modi, il telefono rimane in fastboot.

Link to comment
Share on other sites

Se avviate una finestra cmd nella cartella di GizTWRP (premendo shift + tasto destro in una parte bianca della cartella e selezionando "apri finestra di comando qui") e date il comando "fastboot devices" con il telefono collegato in fastboot che risposta ottenete?

Nel caso vi dia un codice poi vi basterà dare il comando "fastboot -i 0x19d2 flash recovery GizTWRP_z11.img" per eseguire il flash della twrp, il reboot lo potrete fare a mano (tasti power e volume +)

Link to comment
Share on other sites

2 ore fa, Emanuele C dice:

Se avviate una finestra cmd nella cartella di GizTWRP (premendo shift + tasto destro in una parte bianca della cartella e selezionando "apri finestra di comando qui") e date il comando "fastboot devices" con il telefono collegato in fastboot che risposta ottenete?

Nel caso vi dia un codice poi vi basterà dare il comando "fastboot -i 0x19d2 flash recovery GizTWRP_z11.img" per eseguire il flash della twrp, il reboot lo potrete fare a mano (tasti power e volume +)

Ok tenterò domani, sempre "sul pezzo" Emanuele!

Link to comment
Share on other sites

5 ore fa, NicoeNNe dice:

sto riscontrando lo stesso problema pure io, il telefono rimane in fastboot. i driver li ho installati correttamente, era il caso di riavviare il pc dopo averlo fatto?

 

Confermo driver installati e PC avviato...Ma qualcosa non parte: lo z11 resta in fastidiosa boot.

Link to comment
Share on other sites

4 ore fa, PaoloN5 dice:

Confermo driver installati e PC avviato...Ma qualcosa non parte: lo z11 resta in fastidiosa boot.

Non impazzire oltre, prova la twpr del forum ufficiale nubia. Poi fai tutti gli wipe prima e dopo aver installato la rom.

Ultima cosa, non aver paura a provare più volte con la rom, a me rimaneva in bootloop ma la terza volta è andato tutto liscio.

Link to comment
Share on other sites

5 ore fa, NicoeNNe dice:

Non impazzire oltre, prova la twpr del forum ufficiale nubia. Poi fai tutti gli wipe prima e dopo aver installato la rom.

Ultima cosa, non aver paura a provare più volte con la rom, a me rimaneva in bootloop ma la terza volta è andato tutto liscio.

Ok grazie per la dritta!

Link to comment
Share on other sites

Il ‎04‎/‎02‎/‎2017 at 10:49, PaoloN5 dice:

Niente: ho tentato parecchie volte. Ora ho la TWRP (di Massimo R.) che mi consente di installare la Gizrom, ma (pur avendo sostituito il file boot, oltre ad aver tentato con quella standard - che non parte), resta in bootloop. Farò ancora qualche tentativo riscaricando rom e file boot per il dubbio che qualcosa possa essersi corrotta...

P.s. quanto tempo dovrei attendere dopo il riavvio a fine installazione (e pulizia) da TWRP?

Ok grazie per la dritta!

 

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...